I piccioni viaggiatori e Internet

“Le tempeste possono causare perdita di dati”

Stefano T.

2026-10-25

In breve

Fin dall’antichità l’umanità ha addestrato i piccioni per far arrivare messaggi su lunga distanza. Durante la seconda guerra mondiale un piccione viaggiatore irlandese è stato insignito di una medaglia militare per il suo contributo alla missione dello sbarco in Normandia. Internet, per molti, dovrebbe aver reso obsoleto il ruolo di questi coraggiosi volatili, ma l’Internet Engineering Task Force potrebbe non essere d’accordo.

Le Request for Comments: una cosa seria

L’Internet Engineering Task Force (IETF) è un’organizzazione che ha il ruolo fondamentale di sviluppare e promuovere gli standard tecnici utilizzati per far funzionare Internet. Questo preziosissimo compito viene svolto grazie a documenti tecnici chiamati Request for Comments o, in breve, RFC.

Le RFC per Internet e per il web sono una cosa seria. Ad esempio, Tim Berners-Lee, il padre del World Wide Web, descrive con il suo team il funzionamento del protocollo HTTP/1.0 (semplificando: le regole per il trasferimento delle pagine web) con la RFC 1945 del maggio 1996. Le RFC, come già detto, sono una cosa seria. Tranne che per un giorno all’anno.

1º aprile 1990 - RFC 1149

Il primo aprile 1990 viene pubblicata la RFC 1149, intitolata “Standard for the transmission of IP datagrams on avian carriers”. L’autore è David Waitzman, della BBN Systems and Technologies Corporation. L’idea è semplice: stampare su un piccolo rotolo di carta il contenuto di un pacchetto IP (datagramma), codificato in formato esadecimale, legarlo con del nastro adesivo alla zampa di un piccione viaggiatore e lasciare che questo spicchi il volo. All’arrivo a destinazione del piccione, il rotolino di carta viene rimosso dalla zampa e scansionato per essere elaborato elettronicamente. Waitzman ha anche la premura di specificare che i piccioni hanno già di serie un sistema di identificazione e rimozione dei “worm”1 e che le tempeste potrebbero causare perdita dei dati.

In apertura della RFC viene indicato come la proposta sia sperimentale e non consigliata:

This memo describes an experimental method for the encapsulation of IP datagrams in avian carriers. This specification is primarily useful in Metropolitan Area Networks. This is an experimental, not recommended standard. Distribution of this memo is unlimited.

Nel 1999 viene anche proposto un aggiornamento della proposta, con una nuova RFC, pubblicata, non a caso, il primo aprile di quell’anno:

La natura “sperimentale” della specifica non ferma, però, il Linux User Group di Bergen (BLUG), in Norvegia.

L’implementazione e i test

Nel 2001, dopo 11 anni dalla pubblicazione della RFC 1149, il BLUG pensa che sia arrivato, finalmente, il momento di implementare in Linux il supporto al protocollo CPIP (carrier pigeon internet protocol). Organizzano uno specifico Working Group2 e prendono contatti con un’associazione di allevatori di piccioni viaggiatori. Si danno tempo fino al 28 aprile per implementare il software necessario all’interfaccia computer/piccione e per studiare il trasporto “fisico” di questi volatili e fare quindi una dimostrazione pubblica di funzionamento di una rete RFC 1149.

Sono circa le 12:00 del 28 aprile 2001, tutto è pronto per far partire la sessione di ping. Il tempo è buono, nonostante i dintorni di Bergen siano solitamente molto piovosi in quel periodo dell’anno. Uno stormo di piccioni di passaggio distrae quelli utilizzati per il test, ma alla fine i volatili prendono la direzione giusta e tornano a casa. Nonostante due piccioni non avessero più i rotolini con il pacchetto IP ed un packet loss del 55%3, il test viene dichiarato un successo.

Gli sviluppi

I test di interoperabilità con altre reti RFC 1149 sperati dal BLUG, purtroppo, non arrivano, ma la storia del protocollo IPoAC (IP over Avian Carriers) è destinata a non finire. Il primo aprile del 2011 la RFC 1149 riceve un nuovo aggiornamento con la RFC 6214 - “Adaptation of RFC 1149 for IPv6”. I piccioni viaggiatori entrano ufficialmente nell’era IPv6, segno che IPoAC è qui per restare ancora per molto.


  1. “Worm”, la parola inglese per “verme”, è anche il nome di una tipologia di malware.↩︎

  2. “Minutes from BOF #1 of the unofficial CPIP WG | Bergen Linux User Group” su blug.linux.no↩︎

  3. “Log of the ping session” su blug.linux.no↩︎